OWA for Android Pre-Release

Welcome to the OWA for Android Suggestion Box!

Looking to install OWA for Android?

Want to see currently supported devices? Filter the list below on “completed”.

Please note that participation here is totally voluntary and the suggestion box is monitored. If your submission isn’t a suggestion, it might be removed. List items (and item rankings) represent community interest in features, and does not represent an actual priority list for the Microsoft product team.

Please don’t send any novel or patentable ideas, copyrighted materials, samples, or demos for which you don’t want to grant a license to Microsoft. For more info, see the Terms of Service link below.

  1. lg g pro 2

    I am using Android kit kat 4.4.2 on my lg g pro 2 handset and the app after opening and putting all credentials returns error "couldn't connect to server". However on my xiomi mi note 3 which is on android 5.0, the app connects and opens flawlessly.
    Kindly add or help me with owa

    3 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  2. samsung Note-3 Neo

    Kindly add Samsung Note -3 Neo for OWA access.

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  3. Please add Boost View 5.0. 4.2.2

    Please make it compatible with. Boost View 5.0. Version 4.2.2

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  4. add nexus 5x

    add nexus 5x. device is encrypted it still keeps saying encrypt device

    7 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    1 comment  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  5. Add Nexus 6

    Tried everything but can't seem to get around OWA's encryption portion - Says device is already encrypted (in Security), but OWA tries (unsuccessfully) to re-encrypt. It reboots straight back to Home, without having done any "additional" encryption, and continues to ask me to encrypt.

    5 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    1 comment  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  6. Add Google nexus 3

    Adding the support for Google nexus 3 will be good

    3 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  7. 2 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  8. 8 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  9. 1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  10. add Micromax a76

    Please add owa support for Micromax a76

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  11. 2 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  12. 4 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  13. Add Sony xperia M dual

    Please enable/ support for older devices running on Android 4.3 (jelly bean), as Sony is not going to update to Kitkat version, as the hardware of Sony Xperia M dual would not be supporting Android 4.4.4.

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  14. Add Samsung Galaxy Note 2 (Jelly bean 4.3)

    Please add Samsung Galaxy Note 2 devices running on Android version Jelly bean 4.3.

    16 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  15. Please Add Samsung S7582 (Glaxy S Duos 2)

    Please Add Samsung S7582 (Glaxy S Duos 2)

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  16. Add Samsung Galaxy S3 on Jellybean 4.3

    Need S3 on Jellybean 4.3 since Tmobile (and others?) are not upgrading the S3 to Kit kat

    From Tmobile: "Based on the manufactures recommendations, T-Mobile has made the determination not to update the T-Mobile Samsung Galaxy S3 software any further due to the T-Mobile Samsung Galaxy S3 having a dual core processor not the quad core processor it would need to function properly on the KitKat 4.4.4 OS."

    5 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  17. A lot of recent devices will never even get past 4.3, so make it for all 4.x

    Except for the high end or brand new devices, a lot of recent Android phones will never be updated to 4.4 (or 5), so please make the app compatible with all devices starting from 4.x (or at least 4.2)

    21 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    2 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  18. 1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  19. Make it compatible with Android 3.2.1

    Limiting this to Android 4.4 makes it useless for many users of older devices. My tablet is in excellent condition but I need access to OWA.

    5 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  20. 2 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Devices  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

OWA for Android Pre-Release

Categories

Feedback and Knowledge Base